Back to overview

Tally is currently down due to a wider Cloudflare incident.

Nov 18 at 04:00pm CET
Affected services
Tally Application
Tally API
Custom domains

Resolved
Nov 18 at 04:00pm CET

Tally is down due to a Cloudflare incident. We're monitoring and will update when it's normal.

Update

Good news — the Cloudflare outage has been resolved and Tally is back online.

Thanks again for your patience.